When viewing an MSG attachment, receive a "HTTP Error 404 -
File or directory not found." message
Symptom
On an IIS server running on Windows 2003, when viewing an attachment
which is a MSG file (ie. Outlook Email) you will receive the following error.
The page
cannot be found
The page you are looking for might
have been removed, had its name changed, or is temporarily
unavailable.
Please try the following:
- Make sure
that the Web site address displayed in the address bar of
your browser is spelled and formatted correctly.
- If you
reached this page by clicking a link, contact the Web site
administrator to alert them that the link is incorrectly
formatted.
- Click the
Back button to try another link.
HTTP Error 404 -
File or directory not found.
Internet Information Services (IIS)
Technical Information (for
support personnel)
- Go to
Microsoft Product Support Services and perform a title
search for the words HTTP and 404.
- Open
IIS Help, which is accessible in IIS Manager (inetmgr),
and search for topics titled Web Site Setup,
Common Administrative Tasks, and About Custom Error
Messages.
|
Cause
Earlier versions of IIS include a wildcard character MIME mapping,
which permits IIS to serve any file regardless of its extension. IIS 6.0
does not include this wildcard character MIME mapping and does not serve
any type of extension that is not defined at the MimeMap node in the IIS
metabase.
Solution
Please see
Microsoft Knowledgebase Article: IIS 6.0 Does Not Serve Unknown MIME
Types (Article ID 326965) for instructions on adding MSG as a
permitted MIME type.
» Back to FAQ index